Widespread Microsoft Outage Affecting ReSource Pro Services

Major incident Client Portal Platform Policy Insights AdvanceCheck Monthly Insights Report Carrier Insights Submission COE BPM Reports Certs Center Advisory
2026-07-23 15:26 UTC · 3 hours, 15 minutes

Updates

Resolved

Microsoft Resolving Issue

July 23, 2026 · 18:41 UTC
Update

Microsoft mitigation continues. Expect another update around 2:00pm EST.

July 23, 2026 · 17:41 UTC
Investigating

Microsoft is continuing to respond to this outage. Next update will be provided at 1:30pm.

Latest update from Microsoft (https://azure.status.microsoft/en-us/status) says:
“We have identified a potential trigger and are isolating certain impacted devices and redirecting portions of traffic to healthier devices as part of a mitigation plan. We are actively monitoring traffic patterns and service recovery. We will continue to evaluate the effectiveness of mitigation, assess customer impact, and investigate contributing factors. We will provide additional information as soon as it becomes available. “

July 23, 2026 · 17:06 UTC
Issue

We have identified widespread slowness and difficulty logging into our services. This is a result of upstream and widespread outage with Microsoft Azure. Microsoft is aware and actively working on the issue. Next update will occur at 1:00pm EST.

July 23, 2026 · 16:26 UTC

← Back